Delay in email delivery
Incident Report for Patreon
Resolved
We have resolved the issue with email delivery delays. We apologize for the inconvenience.
Posted Feb 02, 2023 - 17:35 PST
Identified
We have identified an issue with email delivery delays and are working on resolving it. We do not currently have an estimate for this fix, but updates will be shared here.
Posted Feb 02, 2023 - 14:56 PST
This incident affected: Notifications (Email notifications).