blog.patreon.com is down
Incident Report for Patreon
Resolved
This incident has been resolved.
Posted Jul 30, 2021 - 09:54 PDT
Investigating
We are currently investigating an issue with blog.patreon.com returning a 404 response to users.
Posted Jul 30, 2021 - 09:28 PDT