Patreon.com is down

Incident Report for Patreon

Resolved

We have mitigated the issue and most users should now be able to access patreon.com as expected, but we expect some intermittent failures over the next hour. Thanks for your patience and understanding.
Posted Jun 10, 2025 - 14:31 PDT

Monitoring

We have identified the issue and are implementing a resolution. We'll share another progress update shortly.
Posted Jun 10, 2025 - 14:13 PDT

Investigating

patreon.com is down for most users. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted Jun 10, 2025 - 14:01 PDT