Payouts Page Not Loading
Incident Report for Patreon
Resolved
We are aware of an incident impacting creator's ability to access their payouts page. Creators can still access their withdraw page by going to the "Withdraw" tab. We will update the status page with more information shortly.
Posted Sep 03, 2024 - 10:01 PDT
Investigating
We are aware of an incident impacting creator's ability to access their payouts page. Creators can still access their withdraw page by going to the "Withdraw" tab. We will update the status page with more information shortly.
Posted Sep 03, 2024 - 09:33 PDT