Intermitted payment failures
Incident Report for Patreon
Resolved
The issue has been resolved, and payment processing is back to normal.
Posted Jun 22, 2023 - 12:28 PDT
Monitoring
We are currently experiencing issues with payment processing that may impact some Apple Pay and American Express transactions. We are monitoring the situation.
Posted Jun 22, 2023 - 11:29 PDT
This incident affected: Payments (Payments Processing).