Lens Web Playback
Incident Report for Patreon
Resolved
We have resolved this issue with Lens video playback on web.
Posted 6 months ago. Mar 15, 2019 - 21:24 PDT
Investigating
We're investigating issues with Lens video playback on web. We'll update here when we know more.
Posted 6 months ago. Mar 15, 2019 - 20:12 PDT
This incident affected: Patreon website (Posts).