Patreon site is down
Incident Report for Patreon
Resolved
We have resolved the issue that was impacting our website availability.
Posted Nov 18, 2024 - 16:50 PST
Investigating
Our website is currently down, we are investigating and will provide an update soon.
Posted Nov 18, 2024 - 16:38 PST