Elevated payment declines
Incident Report for Patreon
Resolved
The issue causing some elevated member payment declines from a specific bank in the UK has been resolved.
Posted Jan 24, 2024 - 11:18 PST
Monitoring
We’ve identified and mitigated an issue causing some elevated member payment declines from a specific bank in the UK.
Posted Jan 22, 2024 - 20:20 PST
Investigating
We've identified some elevated member payment declines from a specific bank in the UK. We're currently working with our processing partners to investigate.
Posted Jan 17, 2024 - 18:54 PST
This incident affected: Payments (Payments Processing).