Payments Failures
Incident Report for Patreon
Resolved
The payments issue is resolved as of 12:38pm. Payments are now processing normally, we will continue to monitor.
Posted 3 months ago. Jun 26, 2019 - 12:47 PDT
Identified
We recently made some changes that led payments to fail over the past hour. We have identified the issue and are working towards a resolution now.
Posted 3 months ago. Jun 26, 2019 - 12:27 PDT
This incident affected: Payments (Payments Processing).