Payment process issues are resolved.

Incident Report for Patreon

Resolved

Payment process issues have been resolved by our vendor. Thank you for your patience.
Posted Apr 05, 2024 - 09:57 PDT

Monitoring

We are seeing improvements on payment process functions and are continuing to work with our vendor to investigate cause. If you continue to experience any issues, please reach out through our help center.
Posted Apr 04, 2024 - 16:33 PDT

Investigating

Payment processing is down for most users. We've identified the issue as a vendor outage. We're working to fix the problem as quickly as we can. We'll share updates as we have progress on resolving the issue.
Posted Apr 04, 2024 - 12:58 PDT