Payments processing impacted for India
Incident Report for Patreon
Resolved
While we're closing the incident, we're continuing to work closely with our payment processing partners to reach a long-term solution. Though we're seeing some recurring payments process successfully, they're not guaranteed to succeed at the same rate prior to the RBI regulations. We'll update impacted creators and patrons once we've reached a resolution with our payment partners.
Posted Dec 03, 2021 - 08:12 PST
Identified
With recent changes in RBI policy for recurring payments, Payment processing for patrons in India is impacted. We are working with partners to resolve this as soon as possible.
Posted Oct 04, 2021 - 12:11 PDT
This incident affected: Payments (Payments Processing).