Partial Service Disruption – Sign-In and Upload Issues

Incident Report for Patreon

Resolved

We're back! Patreon services should be up and running. Thanks for bearing with us.
Posted Jun 12, 2025 - 16:55 PDT

Investigating

We’re currently recovering from a disruption that began on June 12, 2025, due to an outage in an external authentication service, which caused issues with sign-ins and video uploads. We’ve taken steps to mitigate the impact, most services are now stable, and we’ll keep this page updated as we learn more.
Posted Jun 12, 2025 - 14:47 PDT