Paypal Checkout

Incident Report for Patreon

Resolved

We are now successfully processing PayPal transactions.
Posted Feb 06, 2025 - 03:58 PST

Investigating

We are experiencing issues checking out with PayPal right now. We are investigating the issue.
Posted Feb 06, 2025 - 03:36 PST
This incident affected: Payments (Payments Processing).