Tax froms cannot be accessed
Incident Report for Patreon
Resolved
We’re back! Tax forms should be working and accessible as normal. Thanks for bearing with us.
Posted Mar 05, 2024 - 12:55 PST
Investigating
We’re investigating an issue that is preventing access to tax forms for US creators. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted Mar 05, 2024 - 08:28 PST