Data sync issues resulting in inaccurate creator insights

Incident Report for Patreon

Resolved

We have resolved this issue, and all insights and member counts should be displayed accurately. Thank you for your patience!
Posted Oct 01, 2025 - 12:39 PDT

Monitoring

We have identified the cause of this issue, and are working to fully resolve. We will share additional updates as they arise.
Posted Oct 01, 2025 - 12:13 PDT

Identified

We've identified an issue with inaccurate insights, such as member counts, and are actively working on a fix. We'll share an update later today as soon as the issue has been resolved.
Posted Oct 01, 2025 - 11:22 PDT
This incident affected: Patreon website (Creator Dashboard).