Some members lost access to their membership

Incident Report for Patreon

Resolved

This issue has been resolved and membership access has been reinstated for affected members. Thank you for your patience while we looked at this.
Posted Aug 08, 2025 - 12:55 PDT

Investigating

We've identified an issue that is preventing some members from accessing their memberships. We are currently investigating and we will update on this issue as quickly as we can.
Posted Aug 07, 2025 - 13:10 PDT
This incident affected: Patreon website (Posts).