Video uploads are hanging

Incident Report for Patreon

Resolved

Video upload functionality has been restored.
Posted May 14, 2026 - 13:48 PDT

Investigating

New video uploads are hanging. We are investigating the issue.
Posted May 14, 2026 - 13:32 PDT
This incident affected: Patreon website (Posts).