New-cards-unable-to-be-added-for-purchases
Incident Report for Patreon
Resolved
The issue of being unable to add new cards upon checkout has been resolved.
Posted Jul 19, 2024 - 08:22 PDT
Investigating
We are currently investigating an issue where users are unable to add new credit cards to make a purchase on the platform.
Posted Jul 18, 2024 - 16:24 PDT