Elevated declines
Incident Report for Patreon
Resolved
The issue involving some patrons from successfully retrying payments marked as fraudulent has been resolved. Thank you for your patience and cooperation. Should you need additional support, please reach out to our Community Happiness team at by going to our Help Center: https://support.patreon.com/hc/en-us/requests/new
Posted Sep 11, 2023 - 12:33 PDT
Monitoring
We've begun to retry payments that declined as a result of a payments system upgrade, and will continue to do so throughout the month. You can verify the status of your payment by visiting Settings > Billing History. Please note that retrying a payment does not guarantee success, we are continuing to work with our payment partner to minimize declines due to the upgrade moving forward.
Posted Aug 16, 2023 - 09:46 PDT
Update
We are continuing to investigate declined payments caused by a payments system upgrade required by one of our payment partners. We will be retrying all declined payments caused by this issue throughout the month. This means that if your payment was declined, you can expect us to retry that declined charge. (Note: while we'll continue retrying the payment, not all retries are guaranteed to be successful.) We're also working with our partner to identify additional solutions to minimize declines due to the upgrade going forward.
If your payment was declined you can also contact your card issuer to confirm the charge is valid and retry that card, or try a different payment method by visiting Settings > Billing History.
We appreciate your patience while we work to resolve this issue ASAP and are deeply sorry for the interruption.
Posted Aug 07, 2023 - 16:09 PDT
Identified
We've identified and fixed an issue that prevented some patrons from successfully retrying payments marked as fraudulent.
Posted Aug 04, 2023 - 18:28 PDT