High latency RESOLVED

Incident Report for Patreon

Resolved

A latency issue beginning at 11:40 PDT today is now resolved.
Posted May 09, 2025 - 15:19 PDT

Investigating

We are actively looking into site performance issues and latency.
Posted May 09, 2025 - 11:40 PDT