We are experiencing intermittent issues with checkout on Apple Pay

Incident Report for Patreon

Resolved

This incident has been resolved.
Posted Mar 28, 2023 - 19:48 PDT

Investigating

We are experiencing intermittent issues with checkout on Apple Pay, and are investigating the issue.
Posted Mar 28, 2023 - 18:26 PDT
This incident affected: Payments (Pledging).