Login Issues

Incident Report for Patreon

Resolved

We’re investigating an issue that is impacting logins. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted Nov 18, 2025 - 06:37 PST

Investigating

We’re investigating an issue that is impacting logins. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted Nov 18, 2025 - 05:55 PST