Delay in access to benefits after pledge creation
Incident Report for Patreon
Resolved
We have resolved an issue that caused delays in accessing benefits after a patron pledges to a creator.
Posted 5 months ago. May 01, 2019 - 12:53 PDT
Identified
We are resolving an issue with a delay in accessing benefits after a patron pledges to a creator
Posted 5 months ago. May 01, 2019 - 11:40 PDT
This incident affected: Patreon website (Patreon website).