Email Delivery Issue

Incident Report for Patreon

Resolved

The issue affecting email delivery has been resolved, and emails are now resuming.
Posted Feb 25, 2026 - 14:53 PST

Investigating

We’re investigating an issue affecting email delivery that may cause delays. Our team is actively working on a resolution.
Posted Feb 25, 2026 - 14:06 PST
This incident affected: Notifications (Email notifications).