Intermittent Site Performance Issues

Incident Report for Patreon

Resolved

Intermittent site issues have been resolved. Site performance is back to normal.
Posted Feb 27, 2026 - 17:35 PST

Investigating

We’re experiencing intermittent issues across the site impacting performance. We’re actively working on a resolution.
Posted Feb 27, 2026 - 16:48 PST