Intermittent Failures at Checkout Resolved
Incident Report for Patreon
Resolved
The intermittent check out process issues have been resolved and check outs are working again. If you experienced an issue at checkout in the last two hours, please try again. Thank you for your patience.
Posted Feb 06, 2024 - 18:54 PST
Investigating
We are currently experiencing some intermittent failures at checkout for both shops and memberships. We are still investigating and will share another update shortly.
Posted Feb 06, 2024 - 17:19 PST