Some payment methods are currently unavailable

Incident Report for Patreon

Resolved

We have been notified that the underlying issue has been resolved.
Posted Jun 02, 2025 - 12:59 PDT

Monitoring

One of our upstream providers is currently experiencing an issue that affects our ability to accept certain payment methods. We will continue to monitor and provide updates as they become available.
Posted Jun 02, 2025 - 10:51 PDT
This incident affected: Payments (Payments Processing).