Patreon is Down
Incident Report for Patreon
Resolved
We have resolved the outage, thank you for your patience!
Posted 26 days ago. Aug 21, 2019 - 05:45 PDT
Update
We are continuing to investigate this issue.
Posted 26 days ago. Aug 21, 2019 - 05:19 PDT
Investigating
We are currently investigating this issue.
Posted 26 days ago. Aug 21, 2019 - 04:33 PDT
This incident affected: Patreon website (Patreon website).