Issue with new pledge payment for certain languages
Incident Report for Patreon
Resolved
This incident has been resolved.
Posted Aug 01, 2022 - 10:16 PDT
Update
We are continuing to investigate this issue.
Posted Jul 29, 2022 - 16:12 PDT
Investigating
We are aware of an issue regarding pledge payments for a subset of international members and are working to resolve the issue.
Posted Jul 29, 2022 - 14:42 PDT
This incident affected: Payments (Pledging).