Paypal payments declines
Incident Report for Patreon
Resolved
Resolved: This issue has been resolved and PayPal transactions on Patreon are processing successfully.
Posted May 16, 2024 - 11:08 PDT
Identified
Identified: We've identified that payments via Paypal are failing at a higher than normal rate due a vendor issue. We're temporarily blocking payins from PayPal to mitigate this outage. This means fans will have to use other payment methods to complete transactions. We will update this page once we have more information.
Posted May 15, 2024 - 16:01 PDT
Investigating
Investigating: Payments via Paypal are failing at a higher than normal rate. We are looking into the issue and will update this page with more information.
Posted May 15, 2024 - 10:31 PDT