Email Notifications
Incident Report for Patreon
Resolved
This incident has been resolved. Thanks for bearing with us.
Posted Sep 19, 2023 - 20:25 PDT
Monitoring
Our team has deployed a fix and we are monitoring.
Posted Sep 19, 2023 - 16:51 PDT
Investigating
We are experiencing issues with email notifications, our team is currently investigating.
Posted Sep 19, 2023 - 15:24 PDT