Elevated declines
Incident Report for Patreon
Resolved
The issue involving some patrons from successfully retrying payments marked as fraudulent has been resolved. Thank you for your patience and cooperation. Should you need additional support, please reach out to our Community Happiness team at by going to our Help Center: https://support.patreon.com/hc/en-us/requests/new
Posted Sep 11, 2023 - 12:34 PDT
Update
We've traced the slightly elevated decline rates back to payments infrastructure upgrades required by one of our payment processing partners. Patrons might see some payments declined while changes take effect through the payments ecosystem. If you do:
Contact your card issuer to confirm the charge is valid and retry that card, or, if that does not work, try a different payment method
We're deeply sorry for the inconvenience this causes creators and their patrons.
Posted Aug 03, 2023 - 16:28 PDT
Identified
An unrelated issue is causing a slightly higher-than-normal number of patron payments to be erroneously flagged as fraudulent by their banks. We’re sorry for the inconvenience this may cause creators and their patrons. We are working diligently with our partners to resolve this.
Posted Aug 03, 2023 - 07:10 PDT