[status]
Incident Report for Patreon
Resolved
We’re back! Checkouts should be up and running. Thanks for bearing with us.
Posted Jun 27, 2023 - 16:01 PDT
Investigating
We’re having some trouble with checkouts. We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Posted Jun 27, 2023 - 15:35 PDT