Payments errors joining tiers
Incident Report for Patreon
Resolved
The payments processing issues have been resolved. Thank you for your patience.
Posted 6 months ago. Mar 12, 2019 - 19:12 PDT
Update
We are continuing to work on a fix for this issue.
Posted 6 months ago. Mar 12, 2019 - 18:26 PDT
Identified
We are experiencing an issue processing payments, and working to resolve
Posted 6 months ago. Mar 12, 2019 - 17:39 PDT
This incident affected: Payments (Pledging, Payments Processing).