Insights Experiencing Delays

Incident Report for Patreon

Resolved

The issue affecting Insights has been resolved.
Posted Feb 28, 2026 - 07:55 PST

Investigating

We’re currently experiencing issues with Insights that may result in delayed data updates. The team is actively working towards a resolution.
Posted Feb 28, 2026 - 07:03 PST